Nothing Special   »   [go: up one dir, main page]

Lab # 5 To Manipulate Device Configuration and Explain Network Convergence Using Static and Default Routing

Download as pdf or txt
Download as pdf or txt
You are on page 1of 29

FA17-BCE_088 Lab Experiment | 5

Abdullah Nawaz Virk

LAB # 5
To Manipulate Device Configuration and Explain Network Convergence using
Static and Default Routing

Objectives

• Preparation of basic configuration on router based on CLI.


• Be able to manipulate configuration sequence in order prepare, configure and activate serial
and Ethernet interfaces using Packet Tracer.
• To show connectivity between two devices using static routes.
Pre-Lab Exercise
Read this experiment in its entirety to become familiar with objectives of this lab. Also review the portions of
chapter 4 of your reference book and try to understand the Routing algorithms. You may record the terms and
sections that require more elaboration for reference. The instructor may provide the class some time to reflect
upon these before proceeding with the lab.
Routing Basics
Once you create an internetwork by connecting your WANs and LANs to a router, you’ll need to configure
logical network addresses, like IP addresses, to all hosts on that internetwork for them to communicate
successfully throughout it.
The term routing refers to taking a packet from one device and sending it through the network to another device
on a different network. Routers don’t really care about hosts— they only care about networks and the best path
to each one of them. The logical network address of the destination host is key to get packets through a routed
network. It’s the hardware address of the host that’s used to deliver the packet from a router and ensure it arrives
at the correct destination host. List of the minimum factors a router must know to be able to affectively route
packets is:
• Destination address
• Neighbor routers from which it can learn about remote networks
• Possible routes to all remote networks
• The best route to each remote network
• How to maintain and verify routing information
The router learns about remote networks from neighboring routers or from an administrator. It builds a routing
table, which is basically a map of the internetwork, and it describes how to find remote networks. If a network
is directly connected, then the router already knows how to get to it. You have observed in previous lab that
directly connected networks are already in the routing table using show iproute command. The router use one
of the following two ways to learn how to get to the remote network.
• Static Routing
• Dynamic Routing
Static Routing
The static routing method requires someone to hand-type all network locations into the routing table, which can
be a pretty daunting task when used on all but the smallest of networks!
Dynamic Routing
In dynamic routing, a protocol on one router communicates with the same protocol running on neighboring
routers. The routers then update each other about all the networks they know about and place this information
into the routing table. If a change occurs in the network, the dynamic routing protocols automatically inform
Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 50
FA17-BCE_088 Lab Experiment | 5
Abdullah Nawaz Virk

all routers about the event. If static routing is used, the administrator is responsible for updating all changes by
hand onto all routers.
We will discuss dynamic routing in detail in upcoming labs. In this lab we will implement static routing to
access remote networks.
There are some important things you should know about routing protocols before we get deeper into them.
Being familiar with administrative distances, the three different kinds of routing protocols, and routing loops
are three of the most important.
Administrative Distances
The administrative distance (AD) is used to rate the trustworthiness of routing information received on a router
from a neighbor router. An administrative distance is an integer from 0 to 255, where 0 is the most trusted and
255 means no traffic will be passed via this route.
If a router receives two updates listing the same remote network, the first thing the router checks is the AD. If
one of the advertised routes has a lower AD than the other, then the route with the lowest AD will be chosen
and placed in the routing table. If both advertised routes to the same network have the same AD, then routing
protocol metrics like hop count and/or the bandwidth of the lines will be used to find the best path to the remote
network. The advertised route with the lowest metric will be placed in the routing table, but if both advertised
routes have the same AD as well as the same metrics, then the routing protocol will load-balance to the remote
network, meaning the protocol will send data down each link.
Default Administrative Distances
Route Source Default AD

Connected interface 0

Static route 1

EIGRP 90

OSPF 110

RIP 120

As you will progress to dynamic routing you will understand administrative distance and metrics effectively.
For static routing metrics value is 0 as router didn’t make any decision for route its administrator who configured
the routes manually.

In-Lab Exercise
In this lab activity, you will create a network that is similar to the one shown in the Topology Diagram. Begin
by cabling the network as shown in the Figure 12. Use any Class C Network ID and fill in the Addressing Table
to apply an addressing scheme to the network devices. You will then perform the initial router configurations
required for connectivity according to your IP assignment. After completing the basic configuration, test
connectivity between the devices on the network. First test the connections between directly connected devices,
and then test connectivity between devices that are not directly connected. Static routes must be configured on
the routers for end-to-end communication to take place between the network hosts. You will configure the static
routes that are needed to allow communication between the hosts. View the routing table after each static route
is added to observe how the routing table has changed.

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 51
FA17-BCE_088 Lab Experiment | 5
Abdullah Nawaz Virk

Network 2
Topology Diagram

Network 1 Network 3

Figure 12: Network Topology

Addressing Table
Device Interface IP Address Subnet Mask Default Gateway
192.168.10.2/24 255.255.255.0 NA
Fa0/0

R1 192.168.30.1/24 255.255.255.0 NA
S0/0/0

Fa0/0
192.168.20.2/24 255.255.255.0 NA

R2 S0/0/0
192.168.30.3/24 255.255.255.0 NA

S0/0/1
192.168.50.1/24 255.255.255.0 NA

FA0/0
192.168.40.2/24 255.255.255.0 NA

R3 192.168.50.3/24 255.255.255.0 NA
S0/0/1

PC1 NIC
192.168.50.1/24 255.255.255.0 192.168.50.1/24

PC2 NIC
192.168.50.2/24 255.255.255.0 192.168.50.2/24

PC3 NIC
192.168.50.3/24 255.255.255.0 192.168.50.3/24

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 52
FA17-BCE_088 Lab Experiment | 5
Abdullah Nawaz Virk

Task 1: Perform Basic Router Configuration


Draw the topology diagram on Cisco Packet Tracer. Perform basic configuration on all three routers i.e.
assigning IP on LAN and WAN links and other necessary administrative configurations.
Task 2: Configure IP Addressing on the Host PCs
Note: If you have difficulty with any of the commands in task 1 and task 2, see Lab 2
Task 3: Test and Verify the Configurations
Step 1: Test Connectivity of LANs
Test connectivity by pinging from each host to the default gateway that has been configured for that host.
From the host PC1, is it possible to ping the default gateway? yes
From the host PC2, is it possible to ping the default gateway? yes
From the host PC3, is it possible to ping the default gateway? yes
Step 2: Test Connectivity of WANs
Check the router interfaces using the show ip interface brief command. Are all relevant interfaces
up? yes
From the router R2, is it possible to ping R1?
yes

From the router R2, is it possible to ping R3?


yes

Step 3: Routing Table


Run show ip route command on each router and answer the following.
What networks are present in the Topology Diagram but not in the routing table for R1?

C 192.168.10.0/24 is directly connected, FastEthernet0/0


C 192.168.30.0/24 is directly connected, Serial0/0/0
S* 0.0.0.0/0 [1/0] via 192.168.30.2
[1/0] via 192.168.30.3

What networks are present in the Topology Diagram but not in the routing table for R2?

C 192.168.20.0/24 is directly connected, FastEthernet0/0


C 192.168.30.0/24 is directly connected, Serial0/0/0
C 192.168.50.0/24 is directly connected, Serial0/0/1
S* 0.0.0.0/0 [1/0] via 192.168.50.4
[1/0] via 192.168.50

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 53
FA17-BCE_088 Lab Experiment | 5
Abdullah Nawaz Virk

What networks are present in the Topology Diagram but not in the routing table for R3?
C 192.168.40.0/24 is directly connected, FastEthernet0/0
C 192.168.50.0/24 is directly connected, Serial0/0/0
S* 0.0.0.0/0 [1/0] via 192.168.50.4
[1/0] via 192.168.50.2

Why are all the networks not in the routing tables for each of the routers?
Routers can be added statically or dynamically

What can be added to the network so that devices that are not directly connected can ping each other?
It can be filled by statically or dynamically

Task 4: Configure a Static Route Using a Next-Hop Address.


To configure static routes with a next-hop specified, use the following syntax:
Router(config)# iproutenetwork-address subnet-mask ip-address
• network-address—Destination network address of the remote network to be added to the routing table.
• subnet-mask—Subnet mask of the remote network to be added to the routing table. The subnet mask
can be modified to summarize a group of networks.
• ip-address—Commonly referred to as the next-hop router’s IP address.
Step 1: On the R3 router, configure a static route to the network 2 using the Serial 0/0/1 interface of R2
as the next-hop address. Complete the following command and run it on R3.
R3(config)#ip route 192.168.50.3/24 , 255.255.255.0,
Step 2: On the R2 router, configure a static route to reach the network 3using the Serial 0/0/1 interface
of R3 as the next-hop address. Complete the following command and run it on R2.
R2(config)#ip route 192.168.50.1/24 , 255.255.255.0,
Step 3: On the R2 router, configure a static route to reach the network 1 using the Serial 0/0/0 interface
of R1 as the next-hop address. Complete the following command and run it on R2.
R2(config)#ip route 192.168.30.3/24 ,255.255.255.0
Step 4: On the R1 router, configure a static route to the network 2using the Serial 0/0/0 interface of R2
as the next-hop address. Complete the following command and run it on R1.
R1(config)#ip route 192.168.30.1/24, 255.255.255.0
Task 5: Test and Verify the Static Routes
Step 1: View the routing table to verify the new static route entry
Run show ip route command on each router write down your observations.

Static routes have been added to all routers.

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 54
FA17-BCE_088 Lab Experiment | 5
Abdullah Nawaz Virk

Step 2: Use ping to check connectivity.


Ping to check connectivity between the host PC2 and PC1, is ping successful and why?
Failed, because static connection is not established

Ping to check connectivity between the host PC3 and PC2, is ping successful and why?
Failed, because static connection is not established

Ping to check connectivity between the host PC1 and PC3, is ping successful and why?
Successful, because static connection is established

Task 6: Configure a Default Static Route


In the previous steps, you configured the router for specific destination routes. But could you do this for every
route on the Internet? No. The router and you would be overwhelmed. To minimize the size of the routing
tables, add a default static route. A router uses the default static route when there is not a better, more specific
route to a destination.
Instead of filling the routing table of R1 with static routes, we could assume that R1 is a stub router. This means
that R2 is the default gateway for R1. If R1 has packets to route that do not belong to any of R1 directly
connected networks, R1 should send the packet to R2. However, we must explicitly configure R1 with a default
route before it will send packets with unknown destinations to R2. Otherwise, R1 discards packets with
unknown destinations.
To configure a default static route, use the following syntax:
Router(config)#ip route0.0.0.0 0.0.0.0 { ip-address | interface }
Step 1: Configure the R1 router with a default route.
Configure the R1 router with a default route using the Serial 0/0/0 interface of R1 as the next-hop interface. Run
the following command on R1
R1(config)#ip route 0.0.0.0.0.0.0.0 192.168.2.3
View the routing table to verify the new static route entry.
Default static route has been added and represented by S* .

Step 2: Remove static route on R1


As we have set the default route on R1 we don’t need any static route. Remove the static routes that is currently
configured on R1 in Task 4 Step 4 by using the no form of the command.
Note: If this route is not to be deleted it cause no problem to routing. It is just done to show you defaultrouting.
R3(config)#no ip route 192.168.2.0. 255.255.255.0 192.168.2.3

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 55
FA17-BCE_088 Lab Experiment | 5
Abdullah Nawaz Virk
View the routing table to verify the static route entry is deleted.
Yes it has been deleted

Ping to check connectivity between the host PC2 and PC1, is ping successful and why?
Yes, Ping is successful between PC2 and PC1

Step 3: Configure the R3 router with a default route.


Configure the R3 router with a default route using the Serial 0/0/0 interface of R1 as the next-hop interface. Run
the following command on R1
R3(config)#ip route 0.0.0.0.0.0.0.0 192.168.2.1
View the routing table to verify the new static route entry.
Default static route has been added and represented by S*

Step 4: Use ping to check connectivity.


Ping to check connectivity between the host PC2 and PC1, is ping successful.
Yes, Ping is successful between the host PC2 and PC1

Ping to check connectivity between the host PC3 and PC2, is ping successful.
Yes, Ping is successful between the host PC3 and PC2

Ping to check connectivity between the host PC1 and PC3, is ping successful.
No, Ping is not successful between the host PC1 and PC3

Task 7: Summary, Reflection, and Documentation


With the completion of this lab, you have:
• Configured your first network with a combination of static and default routing to provide full
connectivity to all networks
• Observed how a route is installed in the routing table when you correctly configure and activate and
interface

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 56
FA17-BCE_088 Lab Experiment | 5
Abdullah Nawaz Virk

• Learned how to statically configure routes to destinations that are not directly connected
• Learned how to configure a default route that is used to forward packets to unknown destinations
Finally, you should document your network implementation. On each router, capture the following command
output to a text (.txt) file and save for future reference.
• show running-config
• show ip route
• show ip interface brief

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 57
FA17-BCE_088 Lab Experiment | 5
Abdullah Nawaz Virk

Rubric for Lab Assessment


The student performance for the assigned task during the lab session was:
The student completed assigned tasks without any help from the
Excellent 4
instructor and showed the results appropriately.
The student completed assigned tasks with minimal help from the
Good 3
instructor and showed the results appropriately.
The student could not complete all assigned tasks and showed
Average 2
partial results.
Worst The student did not complete assigned tasks. 1

Instructor Signature: Date:

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 58
FA17-BCE-088 Lab Experiment | 6
Abdullah Nawaz Virk
LAB # 6
To Construct a Network and Demonstrate Successful Connectivity between Hosts
where RIP is Configured in Routers using CISCO Packet Tracer

Objectives

• To construct a network for demonstration of the operation of RIP routing protocol using Cisco Packet
Tracer
• To show the connectivity between nodes in a network using RIP on all routers.

Pre-Lab Exercise
Read this experiment in its entirety to become familiar with objectives of this lab. Study in detail and become
familiar with the Dynamic Routing basics provided with this laboratory experiment and in the chapter 4 of the
reference book. You may record the terms and sections that require more elaboration for reference. The
instructor may provide the class some time to reflect upon these before proceeding with the lab.

Dynamic Routing
Dynamic routing is when protocols are used to find networks and update routing tables on routers. This is whole
lot easier than using static or default routing, but it will cost you in terms of router CPU processing and
bandwidth on network links. A routing protocol defines the set of rules used by a router when it communicates
routing information between neighboring routers.
Dynamic routing is further divided into two types as:
• Distance Vector
• Link State
Distance Vector
The distance-vector protocols in use today find the best path to a remote network by judging distance. A
distance-vector routing protocol periodically sends out the entire routing table to directly connected neighbors.
Example of distance vector protocol is Routing Information Protocol (RIP).
Link State
In link-state protocols, the routers each create three separate tables. One of these tables keeps track of directly
attached neighbors, one determines the topology of the entire internetwork, and one is used as the routing table.
Link-state routers know more about the internetwork than any distance-vector routing protocol ever could. Link
state protocols send updates containing the state of their own links to all other directly connected routers on the
network. This is then propagated to their neighbors. Example of link state protocol is OSPF.
In this lab we will learn about distance vector protocol RIP. Link state protocol will be discussed in next lab.
Routing Information Protocol
Routing Information Protocol (RIP) is a true distance-vector routing protocol. RIP sends the complete routing
table out of all active interfaces every 30 seconds. It relies on hop count to determine the best way to a remote
network, but it has a maximum allowable hop count of 15 by default, so a destination of 16 would be considered
unreachable. RIP works okay in very small networks, but it’s super inefficient on large networks with slow
WAN links or on networks with a large number of routers installed and completely useless on networks that
have links with variable bandwidths!
RIP version 1 uses only classful routing, which means that all devices in the network must use the same subnet
mask. This is because RIP version 1 doesn’t send updates with subnet mask information in tow.

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 60
FA17-BCE-088 Lab Experiment | 6
Abdullah Nawaz Virk

RIP version 2 provides something called prefix routing and does send subnet mask information with its route
updates. This is called classless routing. You’ll rarely see RIPv1 used in today’s networks. Even RIPv2 doesn’t
get much attention in the objectives. So why am I even telling you about them? Because it helps me explain
routing protocols a little better before we get into the much more advanced, and very much focused upon, OSPF
protocol.

In-Lab Exercise
In this lab activity, you will create a network that is similar to the one shown in the Topology Diagram. Begin
by cabling the network as shown in the Figure 13. Assign any Network_ID from Class A and fill in the table.
You will then perform the initial router configurations required for connectivity. Use the IP addresses according
to your IP assignment. First test the connections between directly connected devices, and then test connectivity
between devices that are not directly connected. You will configure the dynamic routing protocol RIP to add
remote networks, this will allow communication between the hosts of different networks. View the routing table
after each dynamic route is added to observe how the routing table has changed.

Topology Diagram

Network 3

Network 2
Network 1

Addressing Table
Device Interface IP Address Subnet Mask Default Gateway
192.168.10.2/24 255.255.255.0 NA
Fa0/0

R1 192.168.30.1/24 255.255.255.0 NA
S0/0/0

Fa0/0
192.168.20.2/24 255.255.255.0 NA

R2 S0/0/0
192.168.30.3/24 255.255.255.0 NA

S0/0/1
192.168.50.1/24 255.255.255.0 NA

FA0/0
192.168.40.2/24 255.255.255.0 NA

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 61
FA17-BCE-088 Lab Experiment | 6
Abdullah Nawaz Virk
192.168.50.3/24 255.255.255.0 NA
R3 S0/0/1

PC1 NIC
192.168.50.1/24 255.255.255.0 192.168.50.1/24

PC2 NIC
192.168.50.2/24 255.255.255.0 192.168.50.2/24

PC3 NIC
192.168.50.3/24 255.255.255.0 192.168.50.3/24

Task 1: Perform the Basic Router Configuration


Draw the topology diagram on Cisco Packet Tracer. Perform basic configuration on all three routers i.e.
assigning IP on LAN and WAN links and other necessary administrative configurations.
Task 2: Configure IP Addressing on the Host PCs
Task 3: Test and Verify the Configurations
Note: If you have difficulty with any of the commands in task 1 to task 3, see Lab 2.
Task 4: Configure RIP v1
To configure RIP, use the following syntax:
Enable the dynamic routing protocol RIP, enter global configuration mode and use the router command
Router(config)#router rip
Router(config-router)#networkNETWORK 1
Router(config-router)#networkNETWORK 2
Router(config-router)#networkNETWORK N
NETWORK –Network that is directly connected with that router. You have to enter each directly connected
network separately using network command

Task 5: Enable RIPv1 on Router 1


Step 1: Run following command.
R1(config)#router rip
Step 2: Enter network addresses.
R1(config-router)#network 192.168.10.2
R1(config-router)#network 192.168.30.1

Task 6: Enable RIPv1 on Router 3


Step 1: Run following command.
R3(config)#router rip
Step 2: Complete the following commands and run on R2.
R3(config-router)#network 192.168.40.2
R3(config-router)#network 192.168.50.3

Step 3: Use ping to check connectivity.


Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 62
FA17-BCE-088 Lab Experiment | 6
Abdullah Nawaz Virk

Ping to check connectivity between the host PC2 and PC1, is ping successful and why?
No, connectivity between the host PC2 and PC1 is not successful. Because dynamic connection is
not established

Ping to check connectivity between the host PC3 and PC2, is ping successful and why?
No, connectivity between the host PC3 and PC2 is not successful. Because dynamic connection is
not established

Ping to check connectivity between the host PC1 and PC3, is ping successful and why?
Yes, connectivity between the host PC1 and PC3 is successful. Because dynamic connection

is established

Task 7: Enable RIPv1 on Router 2


Step 1: Run following command.
R2(config)#router rip
Step 2: Complete the following commands and run on R2.
R2(config-router)#network 192.168.20.0
R2(config-router)#network 192.168.30.0
R2(config-router)#network 192.168.50.0

Task 8: Test and verify the routes


Step 1: View the routing table to verify the new route entries
Run show ip route command on each router write down your observations.
Router 1:
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 192.168.30.2 to network 0.0.0.0

C 192.168.10.0/24 is directly connected, FastEthernet0/0


R 192.168.20.0/24 [120/1] via 192.168.30.3, 00:00:11, Serial0/0/0
C 192.168.30.0/24 is directly connected, Serial0/0/0
R 192.168.40.0/24 [120/2] via 192.168.30.3, 00:00:11, Serial0/0/0
R 192.168.50.0/24 [120/1] via 192.168.30.3, 00:00:11, Serial0/0/0
S* 0.0.0.0/0 [1/0] via 192.168.30.2
[1/0] via 192.168.30.3
[1/0] via 192.168.20.2

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 62
FA17-BCE-088 Lab Experiment | 6
Abdullah Nawaz Virk

Router 2:
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 192.168.50.4 to network 0.0.0.0

R 192.168.10.0/24 [120/1] via 192.168.30.1, 00:00:16, Serial0/0/0


C 192.168.20.0/24 is directly connected, FastEthernet0/0
C 192.168.30.0/24 is directly connected, Serial0/0/0
R 192.168.40.0/24 [120/1] via 192.168.50.3, 00:00:24, Serial0/0/1
C 192.168.50.0/24 is directly connected, Serial0/0/1
S* 0.0.0.0/0 [1/0] via 192.168.50.4
[1/0] via 192.168.50.3

Router 3:
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route

Gateway of last resort is 192.168.50.4 to network 0.0.0.0

R 192.168.10.0/24 [120/2] via 192.168.50.1, 00:00:15, Serial0/0/0


R 192.168.20.0/24 [120/1] via 192.168.50.1, 00:00:15, Serial0/0/0
R 192.168.30.0/24 [120/1] via 192.168.50.1, 00:00:15, Serial0/0/0
C 192.168.40.0/24 is directly connected, FastEthernet0/0
C 192.168.50.0/24 is directly connected, Serial0/0/0
S* 0.0.0.0/0 [1/0] via 192.168.50.4
[1/0] via 192.168.50.2
[1/0] via 192.168.30.1

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 63
Lab Experiment | 6

Step 2: What is the value of Administrative Distance for RIP networks?


value of Administrative Distance for RIP networks is 120.

Step 3: What is the metrics value against each network in R1 routing table? Explain it.

R1 R2 R3
R1 0 1 2

Metrics value in R1 routing is determined using hop counts. R2 in R1 routing is 1 because there is 1 hop or 1

Network. For R3 there are 2 hops or R1 can reach to R3 by R2 so Value Is 2

Step 4: Use ping to check connectivity.


Ping to check connectivity between the host PC2 and PC1, is ping successful?
No, connectivity between the host PC2 and PC1 is not successful.

Ping to check connectivity between the host PC3 and PC2, is ping successful?
No, connectivity between the host PC3 and PC2 is not successful

Ping to check connectivity between the host PC1 and PC3, is ping successful?
Yes, connectivity between the host PC1 and PC3 is successful

Task 9: Summary, Reflection, and Documentation


With the completion of this lab, you have:
• Configured your first network with a dynamic routing protocol RIP to provide full connectivity to all
networks
• Observed how a route is installed in the routing table when you correctly configure and activate and
interface
Finally, you should document your network implementation. On each router, capture the following command
output to a text (.txt) file and save for future reference.
• show running-config
• show ip route
• show ip interface brief

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 64
Lab Experiment | 6

Rubric for Lab Assessment


The student performance for the assigned task during the lab session was:
The student completed assigned tasks without any help from the
Excellent 4
instructor and showed the results appropriately.
The student completed assigned tasks with minimal help from the
Good 3
instructor and showed the results appropriately.
The student could not complete all assigned tasks and showed
Average 2
partial results.
Worst The student did not complete assigned tasks. 1

Instructor Signature: Date:

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 65
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk

LAB # 7
To Construct a Network and Demonstrate Successful Connectivity between Hosts
where OSPF is Configured in Routers using CISCO Packet Tracer
Objectives

• To construct a network for demonstration of the operation of OSPF routing protocol using Cisco
Packet Tracer
• To show the connectivity between nodes in a network using OSPF on all routers.

Pre-Lab Exercise
Read this experiment in its entirety to become familiar with objectives of this lab. Study in detail and
become familiar with the Link State Routing basics provided with this laboratory experiment and in
the chapter 4 of the reference book. You may record the terms and sections that require more
elaboration for reference. The instructor may provide the class some time to reflect upon these before
proceeding with the lab.
Open Shortest Path First (OSPF) Basics
Open Shortest Path First (OSPF) is an open standard link state routing protocol that’s been implemented by a
wide variety of network vendors, including Cisco. And it’s that open standard characteristic that’s the key to
OSPF’s flexibility and popularity.
OSPF works by using the Dijkstra algorithm to initially construct a shortest path tree and follows that by
populating the routing table with the resulting best paths. It is quickly convergent. Another two great advantages
OSPF offers are that it supports multiple, equal-cost routes to the same destination, also supports both IP and
IPv6 routed protocols. OSPF’s best features are:
• Allows for the creation of areas and autonomous systems
• Minimizes routing update traffic
• Is highly flexible, versatile, and scalable
• Supports VLSM/CIDR
• Offers an unlimited hop count
• Is open standard and supports multi-vendor deployment
Here are three of the biggest reasons to implement OSPF in a way that makes full use of its intentional,
hierarchical design:
• To decrease routing overhead
• To speed up convergence
• To confine network instability to single areas of the network
OSPF Terminology
Imagine being given a map and compass with no prior concept of east, west, north or south—not even what
rivers, mountains, lakes, or deserts are. I’m guessing that without any ability to orient yourself in a basic way,
your cool, new tools wouldn’t help you get anywhere but completely lost, right? This is exactly why we’re
going to begin exploring OSPF by getting you solidly acquainted with a fairly long list of terms before setting
out from base camp into the great unknown! Here are those vital terms to commit to memory now:
OSPF Metrics
OSPF uses a metric referred to as cost. A cost is associated with every outgoing interface included in an SPF
tree. The cost of the entire path is the sum of the costs of the outgoing interfaces along the path. Cisco uses a

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 66
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk

simple equation of 108/bandwidth, where bandwidth is the configured bandwidth for the interface. Using this
rule, a 100 Mbps Fast Ethernet interface would have a default OSPF cost of 1.
Link
A link is a network or router interface assigned to any given network. When an interface is added to the OSPF
process, it’s considered to be a link. This link, or interface, will have up or down state information associated
with it as well as one or more IP addresses.
Router ID
The router ID (RID) is an IP address used to identify the router. Cisco chooses the router ID by using the highest
IP address of all configured loopback interfaces. If no loopback interfaces are configured with addresses, OSPF
will choose the highest IP address out of all active physical interfaces. To OSPF, this is basically the “name” of
each router.
Neighbor
Neighbors are two or more routers that have an interface on a common network, such as two routers connected
on a point-to-point serial link. OSPF neighbors must have a number of common configuration options to be
able to successfully establish a neighbor relationship, and all of these options must be configured exactly the
same way:
• Area ID
• Stub area flag
• Authentication password (if using one)
• Hello and Dead intervals
Adjacency
An adjacency is a relationship between two OSPF routers that permits the direct exchange of route updates.
Unlike EIGRP, which directly shares routes with all of its neighbors, OSPF is really picky about sharing routing
information and will directly share routes only with neighbors that have also established adjacencies. And not
all neighbors will become adjacent—this depends upon both the type of network and the configuration of the
routers. In multi-access networks, routers form adjacencies with designated and backup designated routers. In
point-to-point and point-to-multipoint networks, routers form adjacencies with the router on the opposite side
of the connection.
Designated Router
A designated router (DR) is elected whenever OSPF routers are connected to the same broadcast network to
minimize the number of adjacencies formed and to publicize received routing information to and from the
remaining routers on the broadcast network or link. Elections are won based upon a router’s priority level, with
the one having the highest priority becoming the winner. If there’s a tie, the router ID will be used to break it.
All routers on the shared network will establish adjacencies with the DR and the BDR which ensures that all
router’s topology tables are synchronized.
Backup Designated Router
A backup designated router (BDR) is a hot standby for the DR on broadcast, or multi-access, links. The BDR
receives all routing updates from OSPF adjacent routers but does not disperse LSA updates.
Hello protocol The OSPF Hello protocol provides dynamic neighbor discovery and maintains neighbor
relationships. Hello packets and Link State Advertisements (LSAs) build and maintain the topological database.
Hello packets are addressed to multicast address 224.0.0.5.
Neighborship Database
The neighborship database is a list of all OSPF routers for which Hello packets have been seen. A variety of
details, including the router ID and state, are maintained on each router in the neighborship database.

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 67
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk

Topological Database
The topological database contains information from all of the Link State Advertisement packets that have been
received for an area. The router uses the information from the topology database as input into the Dijkstra
algorithm that computes the shortest path to every network.
Link State Advertisement
A Link State Advertisement (LSA) is an OSPF data packet containing link-state and routing information that’s
shared among OSPF routers. An OSPF router will exchange LSA packets only with routers to which it has
established adjacencies.
OSPF Areas
An OSPF area is a grouping of contiguous networks and routers. All routers in the same area share a common
area ID. Because a router can be a member of more than one area at a time, the area ID is associated with
specific interfaces on the router. This would allow some interfaces to belong to area 1 while the remaining
interfaces can belong to area 0. All of the routers within the same area have the same topology table. When
configuring OSPF with multiple areas, you’ve got to remember that there must be an area 0 and that this is
typically considered the backbone area. Areas also play a role in establishing a hierarchical network
organization—something that really enhances the scalability of OSPF!
Broadcast (multi-access)
Broadcast (multi-access) networks such as Ethernet allow multiple devices to connect to or access the same
network, enabling a broadcast ability in which a single packet is delivered to all nodes on the network. In OSPF,
a DR and BDR must be elected for each broadcast multi-access network.
Non-Broadcast multi-access
Non-Broadcast multi-access (NBMA) networks are networks such as Frame Relay, X.25, and Asynchronous
Transfer Mode (ATM). These types of networks allow for multi-access without broadcast ability like Ethernet.
NBMA networks require special OSPF configuration to function properly.
Point-to-Point
Point-to-point refers to a type of network topology made up of a direct connection between two routers that
provides a single communication path. The point-to-point connection can be physical—for example, a serial
cable that directly connects two routers—or logical, where two routers thousands of miles apart are connected
by a circuit in a Frame Relay network. Either way, point-to-point configurations eliminate the need for DRs or
BDRs.
Point-to-Multipoint
Point-to-multipoint refers to a type of network topology made up of a series of connections between a single
interface on one router and multiple destination routers. All interfaces on all routers share the point-to-
multipoint connection and belong to the same network. Point-to-multipoint networks can be further classified
according to whether they support broadcasts or not. This is important because it defines the kind of OSPF
configurations you can deploy.

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 68
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk

In-Lab Exercise
In this lab activity, you will create a network that is similar to the one shown in the Topology Diagram. Begin
by cabling the network as shown in the Figure 14. Assign Network_ID from Class B i.e. 172.17.0.0/24 and fill
in the table. The segments of the network have been subnetted using VLSM.OSPF is a classless routing protocol
that can be used to provide subnet mask information in the routing updates. This will allow VLSM subnet
information to be propagated throughout the network. You will then perform the initial router configurations
required for connectivity. Use the IP addresses according to your IP assignment. First test the connections
between directly connected devices, and then test connectivity between devices that are not directly connected.
You will configure the dynamic routing protocol OSPF to add remote networks, this will allow communication
between the hosts of different networks. View the routing table after each dynamic route is added to observe
how the routing table has changed.
Topology Diagram Network 2

Network 1 Network 3

Figure 14: Network Topology

Addressing Table
Device Interface IP Address Subnet Mask Default Gateway

Fa0/0 172.16.1.21 255.255.255.240 N/A

R1 S0/0/0 192.168.10.2 255.255.255.252 N/A

S0/0/1 192.168.10.10 255.255.255.252 N/A

Fa0/0 10.10.10.10 255.255.255.0 N/A

R2 S0/0/0 192.168.10.25 255.255.255.252 N/A

S0/0/1 192.168.10.2 255.255.255.252 N/A

Fa0/0 172.16.1.37 255.255.255.240 N/A

R3 S0/0/0 198.168.10.11 255.255.255.0 N/A

S0/0/1 192.168.10.9 255.255.255.252 N/A

PC1 NIC 172.16.1.20 255.255.0.0 172.16.1.21

PC2 NIC 10.10.10.24 255.255.255.0 10.10.10.10

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 69
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk

PC3 NIC 172.16.1.36 255.255.255.240 172.16.1.37


Task 1: Prepare the Network
Task 2: Perform Basic Router Configurations.
Step 1: Configure and Activate Serial and Ethernet interfaces on R1, R2, and R3.
Step 2: Verify IP addressing and interfaces.
Use the show ip interface brief command to verify that the IP addressing is correct and that the interfaces are
active.

R1 Basic configuration:
Router> show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 172.16.1.21 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/1/0 192.168.10.2 YES manual up up
Serial0/1/1 192.168.10.10 YES manual up up
Loopback0 10.1.1.1 YES manual up up
Vlan1 unassigned YES unset administratively down down

R2 Basic configuration:

Router#show ip interface brief


Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.10.10.10 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/1/0 192.168.10.25 YES manual up up
Serial0/1/1 192.168.10.2 YES manual up up
Loopback0 10.2.2.2 YES manual up up
Vlan1 unassigned YES unset administratively down down

R3 Basic configuration:
Router>show ip interface brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 172.16.1.37 YES manual up up
FastEthernet0/1 unassigned YES unset administratively down down
Serial0/1/0 198.168.10.11 YES manual up up
Serial0/1/1 192.168.10.9 YES manual up up
Loopback0 10.3.3.3 YES manual up up
Vlan1 unassigned YES unset administratively down down

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 70
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk

Task 3: Perform IP configuration on host PC’s


Task 4: Configure OSPF
Step 1: Learn how to enable OSPF
Router(config)#router ospfProcess ID
Router(config-router)#network Network1 Wildcard mask area OSPF areas
Router(config-router)#networkNetwork2 Wildcard mask area OSPF areas
.
.
Router(config-router)#networkNetworkN Wildcard mask area OSPF areas
Process ID: A value in the range from 1 to 65,535 identifies the OSPF process ID. It’s a unique number on this
router that groups a series of OSPF configuration commands under a specific running process. Different OSPF
routers don’t have to use the same process ID to communicate. It’s a purely local value that doesn’t mean a lot,
but you still need to remember that it cannot start at 0; it has to start at a minimum of 1.
Network – Network that is directly connected with that router. You have to enter each directly connected
network (range from 1 to N) separately using network command
Wildcard mask – Inverse of a subnet mask. For Example, the inverse of the subnet mask255.255.255.0 is
0.0.0.255. To calculate the inverse of the subnet mask, subtract the subnet mask from 255.255.255.255:

255.255.255.255

– 255.255.255.0 Subtract the subnet mask

-------------------------

0. 0. 0. 255 Wildcard mask

OSPF areas–An OSPF area is a grouping of contiguous networks and routers. All routers in the same area
share a common area ID. Because a router can be a member of more than one area at a time, the area ID is
associated with specific interfaces on the router. This would allow some interfaces to belong to area 1 while the
remaining interfaces can belong to area 0. All of the routers within the same area have the same topology table.
When configuring OSPF with multiple areas, you’ve got to remember that there must be an area 0 and that this
is typically considered the backbone area. Areas also play a role in establishing a hierarchical network
organization—something that really enhances the scalability of OSPF!

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 71
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk
Task 5: Configure OSPF on the R1 Router
Step 1: Enable OSPF. Use the router ospf command in global configuration mode to enable OSPF on the
R1 router. Enter a process ID of 1 for the process-ID parameter.
R1(config)#router ospf 1
Step 2: Configure the networks
Once you are in the Router OSPF configuration sub-mode, configure the networks to be included in the OSPF
updates that are sent out of R1 i.e. networks directly connected with R1.
Step 3: Configure the Network 1
Wildcard mask has been calculated for this network in wildcard mask example i.e. 0.0.0.255. Complete the
following command and configure it on Router 1. Enter OSPF area of 0 for the OSPF areas parameter. You
will use same OSPF area for whole lab.
R1(config-router)#network 172.16.1.21 0.0.0.15 area 0
Step 4: Configure the router to advertise the networks attached to the Serial0/0/0 and Serial0/0/1 interface
respectively.
Calculate the wildcard mask for the network, complete the following commands and enter in Router OSPF
configuration sub-mode.
R1(config-router)#network 192.168.10.2 0.0.0.3 area 0
R1(config-router)#network 192.168.10.10 0.0.0.3 area 0

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 72
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk
Step 5: When you are finished with the OSPF configuration for R1, return to privileged EXEC mode and
save the current configuration to NVRAM.
R1(config-router)#end

Task 6: Configure OSPF on the R2 and R3 Routers


Step 1: Enable OSPF routing on the R2 router. Write the command to enable OSPF.
command to enable OSPF is router ospf 2

Step 2: Configure the router R2 to advertise the directly connected networks. Write down the commands
and run in Router OSPF configuration sub-mode.

Network 10.10.10.10 0.0.0.255 area 0

Network 192.168.10.25 0.0.0.3 area 0


Network 192.168.10.2 0.0.0.3 area 0

Step 3: Notice that Link State protocol sends a notification message to the console stating that a neighbor
relationship with another OSPF router has been established.
What is the IP address of the OSPF neighbor router?
IP address of the OSPF neighbor router is: 192.168.10.9

What interface on the R2 router is the neighbor adjacent to?


Interface on the R2 router is the neighbor adjacent to: Serial0/1/0

Step 4: Enable OSPF routing on the R3 router. Write the command to enable OSPF.
command to enable OSPF is router ospf 3

Step 5: Configure the router R3 to advertise the directly connected networks. Write down the commands
and run in Router OSPF configuration sub-mode.

Network 172.16.1.37 0.0.0.15 area 0

Network 198.168.10.11 0.0.0.255 area 0


Network 192.168.10.9 0.0.0.3 area 0

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 73
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk

Task 7: Configure OSPF Router IDs


The OSPF router ID is used to uniquely identify the router in the OSPF routing domain. A router ID is an IP
address. Cisco routers derive the Router ID in one of three ways and with the following precedence:
• IP address configured with the OSPF router-id command.
• Highest IP address of any of the router’s loopback addresses.
• Highest active IP address on any of the router’s physical interfaces.
Step 1: Examine the current router IDs in the topology.
Since no router IDs or loopback interfaces have been configured on the three routers, the router ID for each
router is determined by the highest IP address of any active interface. Run the following command on each
router to check router ID
Router#show ip protocols
What is the router ID for R1?
Router ID 10.1.1.1 show ip ospf

What is the router ID for R2?


Router ID 192.168.10.9

What is the router ID for R3?


Router ID 198.168.10.11

Step 2: Use loopback addresses to change the router IDs of the routers in the topology.
R1(config)#interface loopback 0
R1(config-if)#ip address 10.1.1.1 255.255.255.255
R2(config)#interface loopback 0
R2(config-if)#ip address 10.2.2.2 255.255.255.255
R3(config)#interface loopback 0
R3(config-if)#ip address 10.3.3.3 255.255.255.255
Step 3: Reload the routers to force the new Router IDs to be used.

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 74
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk

When a new Router ID is configured, it will not be used until the OSPF process is restarted. Make sure that the
current configuration is saved to NRAM, and then use the reload command to restart each of the routers.
When the router is reloaded, what is the router ID for R1? ID 10.1.1.1
When the router is reloaded, what is the router ID for R2? ID 10.2.2.2
When the router is reloaded, what is the router ID for R3? ID 10.3.3.3
Step 4: Use the show ipospfneighbors command to verify that the router IDs have changed.

Task 8: Verify OSPF Operation


Step 1: On the R1 router, Use the show ip ospfneighbor command and write your observations.
R1#show ip ospfneighbor
Neighbor ID Pri State Dead Time Address Interface
10.2.2.2 0 FULL/- 00:00:34 192.168.10.11
Serial0/0/0
10.3.3.3 0 FULL/- 00:00:34 192.168.10.9
Serial0/0/1

Step 2: On the R1 router, use the show ip protocols command and write your observations.
R1#show ip protocols
Routing Protocol is "ospf 1"
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Router ID 10.1.1.1
Number of areas in this router is 2. 2 normal 0 stub 0 nssa
Maximum path: 4
Routing for Networks:
192.168.10.4 0.0.0.3 area 1
172.16.1.16 0.0.0.15 area 0
192.168.10.0 0.0.0.3 area 0
192.168.10.8 0.0.0.3 area 0
Routing Information Sources:
Gateway Distance Last Update
10.1.1.1 110 00:03:39
Distance: (default is 110)

Step 3: Examine OSPF Routes in the Routing Tables


R1#show ip route

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 75
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk

Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B – BGP


D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E – EGP
i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
* - candidate default, U - per-user static route, o - ODR
P - periodic downloaded static route
Gateway of last resort is not set
10.0.0.0/32 is subnetted, 1 subnets
C 10.1.1.1 is directly connected, Loopback0
172.16.0.0/28 is subnetted, 1 subnets
C 172.16.1.16 is directly connected, FastEthernet0/0
192.168.10.0/30 is subnetted, 2 subnets
C 192.168.10.0 is directly connected, Serial0/1/0
C 192.168.10.8 is directly connected, Serial0/1/1

Step 4: Repeat Step 1 to Step 3 for Router R2 and R3

Neighbor ID Pri State Dead Time Address Neighbor ID Pri State Dead Time Address
Interface Interface
10.3.3.3 0 FULL/ - 00:00:35 192.168.10.10 10.2.2.2 0 FULL/ - 00:00:32 192.168.10.11
Serial0/0/1
Serial0/0/1 10.1.1.1 0 FULL/ - 00:00:38 192.168.10.9
10.1.1.1 0 FULL/ - 00:00:30 192.168.10.1 Serial0/0/0
Serial0/0/0

Step 5: Use ping command to access PC1 to PC2 and PC1 to PC3 verify that OSPF is configured correctly.
Is ping successful?
No it is not successful

Step 6: Use the show interfaces serial0/0/0 command on the R1 router to view the bandwidth of the Serial
0/0/0 interface. What is the default bandwidth of link?
R1#show interfaces serial0/0/0

the default bandwidth of link is BW 64 Kbit

Step 7: Calculate the cost of link to find metrics value using the formula 108/bandwidth. Is calculate and
router measured value same?
Cost: 1562. Yes, it is same.
Task 9: Configure Additional Features
Step 1: Use the bandwidth command to change the bandwidth of the serial interface serial0/0/0 of the R1
and R2 routers to the actual bandwidth, 64 kbps.
R1 router:
R1(config)#interface serial0/0/0

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 76
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk
R1(config-if)#bandwidth 64
R2 router:
R2(config)#interface serial0/0/0
R2(config-if)#bandwidth 64

Step 2: Use the show ipospf interface command on the R1 router to verify the cost of the serial links. What
is new cost of serial0/0/0 link?

New cost of serial0/1/0 link: 41.

Step 3: Use the show ipospfneighbor command on R1 to view the Dead Time counter. What is default
dead interval and what do you observe?

Dead time is 34
The Dead Time counter is counting down from the default interval of 40 seconds.

Step 4: Configure the OSPF Hello and Dead intervals.


The OSPF Hello and Dead intervals can be modified manually using theipospf hello-intervalandipospf dead-
intervalinterface commands. Use these commands to changethe hello interval to 5 seconds and the dead interval
to 20 seconds on the Serial 0/0/0 interface of the R1 router.
R1(config)#interface serial0/0/0
R1(config-if)#ipospf hello-interval 5
R1(config-if)#ipospf dead-interval 20
Step 5: Modify the Dead Timer and Hello Timer intervals on the Serial 0/0/0 interface in the R2 router
to match the intervals configured on the Serial 0/0/0 interface of the R1 router.
R2(config)#interface serial0/0/0
R2(config-if)#ipospf hello-interval 5
R2(config-if)#ipospf dead-interval 20

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 77
FA17-BCE-088 Lab Experiment | 7
Abdullah Nawaz Virk

Rubric for Lab Assessment


The student performance for the assigned task during the lab session was:
The student completed assigned tasks without any help from the
Excellent 4
instructor and showed the results appropriately.
The student completed assigned tasks with minimal help from the
Good 3
instructor and showed the results appropriately.
The student could not complete all assigned tasks and showed
Average 2
partial results.
Worst The student did not complete assigned tasks. 1

Instructor Signature: Date:

Modassir Ishfaq |CPE 314 |Data Communications and Computer Network Lab Manual 78

You might also like