Nothing Special   »   [go: up one dir, main page]

17-Troubleshooting EtherChannel II

Download as pdf or txt
Download as pdf or txt
You are on page 1of 12

Lab ID: 9.9K516A198.TSP.

Troubleshooting EtherChannel II
Objective
Analyze, locate, and fix EtherChannel problems on your network, which could be caused by
misconfiguration or incorrect design.

Lab Topology
The topology diagram below represents the NetMap in the Simulator.

ASW1 DSW1 CSW1

Command Summary
Command Description
channel-group port-channel-number assigns an Ethernet interface to an EtherChannel group
mode {on | auto [non-silent] | desirable
[non-silent] | active | passive}
configure terminal enters global configuration mode from privileged EXEC
mode
enable enters privileged EXEC mode
end ends and exits configuration mode
exit exits one level in the menu structure
interface type number changes from global configuration mode to interface
configuration mode
interface range gigabitethernet slot/ configures a range of interfaces
starting-port - ending-port
lacp port-priority priority-value configures the Link Aggregation Control Protocol (LACP)
priority for the interface
lacp system-priority priority-value configures the LACP priority for the system
show cdp neighbors displays information about directly connected neighbors
show etherchannel [channel-group- displays EtherChannel information for a channel
number] {detail | load-balance | port |
port-channel | summary | protocol}]
show running-config displays the active configuration file
show running-config interface type displays the specified interface’s active configuration file
number
show spanning-tree displays spanning tree state information
shutdown; no shutdown disables an interface; enables an interface

1 Boson NetSim Lab Manual


Lab Tasks
Complex network troubleshooting requires a structured approach. Network documentation that includes
thorough troubleshooting procedures can decrease the amount of time required to resolve network
problems. Troubleshooting procedures should contain a process to diagnose problems and the steps
necessary to verify that a proposed solution resolved the problem. In this lab, this is referred to as a
troubleshooting and verification plan.

Trouble Ticket 1: Optimizing Redundancy


Sporadic errors on FastEthernet 0/3 of ASW1 have caused concern that the interface may be prone to
failure in the near future. You’ve been asked to take steps to see that this interface is used as a last resort
in the channel group it is a part of. Take the necessary steps and verify your solution.

Trouble Ticket 2: Troubleshooting a Spanning Tree Loop


A junior network administrator is assigned to configure the EtherChannel between DSW1 and CSW1.
While configuring DSW1, the junior administrator detected a spanning tree loop. You have been asked to
determine what caused the loop and to make the necessary changes to correct it.

You can do so by clicking the Grade Lab icon ( ) in the toolbar or by pressing Ctrl+G.

2 Boson NetSim Lab Manual


Lab Solutions
Trouble Ticket 1: Optimizing Redundancy
Sporadic errors on FastEthernet 0/3 of ASW1 have caused concern that the interface may be prone to
failure in the near future. You’ve been asked to take steps to see that this interface is used as a last resort
in the channel group it is a part of. Take the necessary steps and verify your solution.

You should create a troubleshooting and verification plan before attempting to correct the problem. There
are several possible solutions to this task. You will be working on ASW1 and DSW1 in this task. The
following are steps that you can take to resolve the issue:
1. EtherChannel technology can provide several benefits to networks, including load balancing and link
redundancy. You should first document each port-channel interface on ASW1; include the device it is
connected to and its operational status. Document the properties of the channel group, including the
state of each member interface and which negotiation protocol, if any, is in use.

In the following steps, you will go through the process of making the required configuration changes
to ensure that FastEthernet 0/3 is included in the channel group but only used as a backup with low
priority. You will also verify your changes by simulating failure in other links in the EtherChannel and
observing whether FastEthernet 0/3 is used as last resort substitute.

2. EtherChannel requires a minimum of two links between devices. You should issue the following
command on ASW1 to display the neighbor relationships; the FastEthernet 0/1 - FastEthernet 0/10
ports form links to the FastEthernet 0/1 - FastEthernet 0/10 ports on DSW1. These 20 ports form 10
links that can be configured to form a channel group between ASW1 and DSW1.

ASW1#show cdp neighbors


Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S -Switch, H - Host, i - IGMP, r - Repeater
Device ID Local Intrfce Holdtme Capability Platform Port ID
DSW1 Fas0/1 129 T S 3550 Fas 0/1
DSW1 Fas0/2 129 T S 3550 Fas 0/2
DSW1 Fas0/3 129 T S 3550 Fas 0/3
DSW1 Fas0/4 129 T S 3550 Fas 0/4
DSW1 Fas0/5 129 T S 3550 Fas 0/5
DSW1 Fas0/6 129 T S 3550 Fas 0/6
DSW1 Fas0/7 129 T S 3550 Fas 0/7
DSW1 Fas0/8 129 T S 3550 Fas 0/8
DSW1 Fas0/9 129 T S 3550 Fas 0/9
DSW1 Fas0/10 129 T S 3550 Fas 0/10

3 Boson NetSim Lab Manual


3. Issue the following command on ASW1 to view details of the existing EtherChannel. The negotiation
protocol being used by Port-Channel 1 is LACP, which supports up to eight active links and
16 links total. FastEthernet 0/1 - FastEthernet 0/8 are bundled ( P), whereas FastEthernet 0/9
and FastEthernet 0/10 are in hot standby mode ( H). The hot standby interfaces will be used as
substitutes if any of the bundled links become inactive in the EtherChannel. Sample output is shown
below:

ASW1#show etherchannel summary


Flags: D - down P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use f - failed to allocate aggregator

M - not in use, minimum links not met


u - unsuitable for bundling
w - waiting to be aggregated
d - default port

Number of channel-groups in use: 1


Number of aggregators: 1

Group Port-channel Protocol Ports


---------------------------------------------------------------
1 Po1(US) LACP Fa0/1(Pd) Fa0/2(P) Fa0/3(P) Fa0/4(P)
Fa0/5(P) Fa0/6(P) Fa0/7(P) Fa0/8(P) Fa0/9(H) Fa0/10(H)

4. LACP uses a configurable port priority value for each interface to determine which interfaces
become bundled (bndl) in the port channel and which ones are placed in hot standby mode ( hot-
sby). Interfaces with lower values are prioritized above interfaces with higher values. If the port
priorities are configured the same or left as the default (32768), the port number is used instead.
Issue the following command on ASW1 to view details, including the LACP port priority, of each
member port. All of the interfaces on ASW1 are configured with the default value, so in this scenario
the port number will determine the priority. Sample output is shown below:

ASW1#show etherchannel port


Channel-group listing:
----------------------
Group: 1
----------
Ports in the group:
-------------------
Port: Fa0/1
------------

Port state = Up Mstr In-Bndl


Channel group = 1 Mode = Passive Gccchange = 0
Port-channel = Po1 GC = 0x00000101 Psuedo port-channel = Po1
Port index = 1 Load = 0x00 Protocol = LACP
(continued on next page)

4 Boson NetSim Lab Manual


(continued from previous page)

Flags: S - Device is sending Slow LACPDUs F - Device is sending fast LACPDUs.


A - Device is in active mode. P - Device is in passive mode.

Local information:
LACP port Admin Oper Port Port
Port Flags State Priority Key Key Number State
Fa0/1 SP bndl 32768 0x3 0x3 0x2 0x3C

Partner’s information:

LACP port Admin Oper Port Port


Port Flags Priority Dev ID Age key Key Number State
Fa0/1 SA 32768 000C.1380.3538 20s 0x0 0x3 0x2 SA

<output omitted>

5. In order to configure FastEthernet 0/3 so that it is used as the lowest priority interface of the
EtherChannel, you should configure the LACP priority to be higher than the other member
interfaces. On ASW1, issue the following commands to change the priority to the maximum value of
65535 so that it is higher than the default value 32768:

ASW1(config)#interface fastethernet 0/3


ASW1(config-if)#lacp port-priority 65535

6. On ASW1, issue the following command to see whether there have been any changes to the state
of the member interfaces. By lowering the priority of FastEthernet 0/3, you might expect that it would
replace FastEthernet 0/9 as a hot standby interface. It appears, however, that there has been no
change and FastEthernet 0/9 and FastEthernet 0/10 are still the only two interfaces in hot standby
mode.

ASW1#show etherchannel summary


<output omitted>

Number of channel-groups in use: 1


Number of aggregators: 1

Group Port-channel Protocol Ports


---------------------------------------------------------------
1 Po1(US) LACP Fa0/1(Pd) Fa0/2(P) Fa0/3(P) Fa0/4(P)
Fa0/5(P) Fa0/6(P) Fa0/7(P) Fa0/8(P) Fa0/9(H) Fa0/10(H)

5 Boson NetSim Lab Manual


7. LACP dictates that only one device of an EtherChannel can make decisions about which interfaces
are placed in hot standby mode. The global LACP system priority value is used to determine which
device becomes the decision-maker. If each switch is configured with the same system priority, the
one with the lower switch Media Access Control (MAC) address will become the decision-maker.
ASW1 and DSW1 are both configured with the default LACP system priority (32768). By issuing the
following command on ASW1 and DSW1, you can observe the switch MAC address of each device
(indicated by the Bridge ID) and determine that, in this scenario, DSW1 is the decision-maker.
Sample output is shown below:

ASW1#show spanning-tree
VLAN0001
Spanning tree enabled protocol pvst
Root ID Priority 32768
Address 000C.1289.3959
Cost 23
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768


Address 000C.3388.4866
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 15

Interface Role Sts Cost Prio.Nbr Type


------------------- ---- --- --------- -------- -----------------------------
Fa0/11 Desg FWD 19 128.11 P2p
Po1 Root FWD 23 128.14 P2p

DSW1#show spanning-tree
VLAN0001
Spanning tree enabled protocol pvst
Root ID Priority 32768
Address 000C.1289.3959
Cost 4
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768


Address 000C.1380.3538
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 15

Interface Role Sts Cost Prio.Nbr Type


------------------- ---- --- --------- -------- -----------------------------
Po1 Desg FWD 42 128.16 P2p
Po2 Root FWD 4 128.17 P2p

8. On ASW1, issue the following command to configure ASW1 with a priority of 100 (any number
between 1 and 32767 can be used, but this lab is graded on the entry of 100). This will make ASW1
the decision-maker and allow it to dictate which links are placed in hot standby mode.

ASW1(config)#lacp system-priority 100

6 Boson NetSim Lab Manual


9. On ASW1, issue the following command to verify that FastEthernet0/3 has replaced FastEthernet0/9
as a hot standby interface. Sample output is shown below:

ASW1#show etherchannel summary


<output omitted>

Number of channel-groups in use: 1


Number of aggregators: 1

Group Port-channel Protocol Ports


---------------------------------------------------------------
1 Po1(US) LACP Fa0/1(Pd) Fa0/2(P) Fa0/3(H) Fa0/4(P)
Fa0/5(P) Fa0/6(P) Fa0/7(P) Fa0/8(P) Fa0/9(P) Fa0/10(H)

10. FastEthernet 0/3 and FastEthernet 0/10 should now both be in hot standby mode. To verify that
FastEthernet 0/10 will be selected as an active interface before FastEthernet 0/3, you can shut down
one of the active links in the EtherChannel and observe which hot standby interface is selected to
become active.

ASW1(config)#interface fastethernet 0/1


ASW1(config-if)#shutdown
ASW1(config-if)#do show etherchannel summary
<output omitted>

Number of channel-groups in use: 1


Number of aggregators: 1

Group Port-channel Protocol Ports


---------------------------------------------------------------
1 Po1(US) LACP Fa0/1(D) Fa0/2(Pd) Fa0/3(H) Fa0/4(P)
Fa0/5(P) Fa0/6(P) Fa0/7(P) Fa0/8(P) Fa0/9(P) Fa0/10(P)

Trouble Ticket 2: Troubleshooting a Spanning Tree Loop


A junior network administrator is assigned to configure the EtherChannel between DSW1 and CSW1.
While configuring DSW1, the junior administrator detected a spanning tree loop. You have been asked to
determine what caused the loop and to make the necessary changes to correct it.

You should create a troubleshooting and verification plan before attempting to correct the problem. There
are several possible solutions to this task. You will be working on DSW1 and CSW1 in this task. The
following are steps that you can take to resolve the issue:
1. The junior network administrator halted work upon detection of a spanning tree loop. You should
first document the state of the EtherChannel between DSW1 and CSW1, including configuration
of member interfaces and which negotiation protocol, if any, is in use. In an EtherChannel
configuration, all member interfaces should be configured similarly without differences: speed,
duplex, native VLAN, VLAN range, trunking status and type should all be the same. If a negotiation
protocol is being used, both devices must use the same protocol in order to successfully negotiate
the link. Since this scenario involves a spanning tree loop, you should observe the spanning tree
details, including the interface port states. Determine which interfaces are causing the loop, and
correct the problem.

7 Boson NetSim Lab Manual


2. You should issue the following command on DSW1 and CSW1 to determine which interfaces
are connected to CSW1. The sample output from DSW1 indicates that GigabitEthernet0/1 and
GigabitEthernet0/2 are connected to CSW1. The sample output from CSW1 indicates that
GigabitEthernet0/1 and GigabitEthernet0/2 are connected to DSW1.

DSW1#show cdp neighbors


Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S -Switch, H - Host, i - IGMP, r - Repeater
Device ID Local Intrfce Holdtme Capability Platform Port ID
CSW1 Gig0/1 151 T S 3550 Gig 0/1
CSW1 Gig0/2 151 T S 3550 Gig 0/2
<output omitted>

CSW1#show cdp neighbors


Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
S -Switch, H - Host, i - IGMP, r – Repeater
Device ID Local Intrfce Holdtme Capability Platform Port ID
DSW1 Gig0/1 155 T S 3550 Gig 0/1
DSW1 Gig0/2 155 T S 3550 Gig 0/2

3. View any configuration changes made to the GigabitEthernet interfaces on DSW1 and CSW1 by
using the show running-config interface interface-id command. The output indicates that both
GigabitEthernet0/1 and GigabitEthernet0/2 are configured to trunk unconditionally using 802.1Q
encapsulation. On DSW1, the interfaces are also configured as members of channel-group 2 with no
negotiation protocol being used.

DSW1#show running-config interface gigabitethernet 0/1


Building configuration...
Current configuration : 122 bytes
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode on
end

DSW1#show running-config interface gigabitethernet 0/2


Building configuration...
Current configuration : 122 bytes
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
channel-group 2 mode on
end

CSW1#show running-config interface gigabitethernet 0/1


Building configuration...
Current configuration : 96 bytes
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport mode trunk
end

(continued on next page)

8 Boson NetSim Lab Manual


(continued from previous page)

CSW1#show running-config interface gigabitethernet 0/2


Building configuration...
Current configuration : 96 bytes
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport mode trunk
end

4. EtherChannel mode on will bundle interfaces irrespective of the configuration of the interfaces on the
opposite side of the link. Once interfaces are up and bundled, the port-channel interface changes
to an up state and is added to the spanning tree as a single logical link, replacing the bundled
member interfaces. Issue the following command on DSW1 and CSW1 to verify the port states in
the spanning tree on DSW1 and CSW1. You should observe that interface Port-Channel 2 on DSW1
is in a forwarding state and at the same time interfaces GigabitEthernet 0/1 and GigabitEthernet 0/2
on CSW1 are also forwarding.

DSW1#show spanning-tree
VLAN0001
Spanning tree enabled protocol pvst
Root ID Priority 32768
Address 000C.1289.3959
Cost 4
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768


Address 000C.1380.3538
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 15

Interface Role Sts Cost Prio.Nbr Type


------------------- ---- --- --------- -------- -----------------------------
Po1 Desg FWD 42 128.16 P2p
Po2 Root FWD 4 128.17 P2p

CSW1#show spanning-tree
VLAN0001
Spanning tree enabled protocol pvst
Root ID Priority 32768
Address 000C.1289.3959
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768


Address 000C.1289.3959
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 15

Interface Role Sts Cost Prio.Nbr Type


------------------- ---- --- --------- -------- -----------------------------
Gi0/1 Desg FWD 0 128.13 P2p
Gi0/2 Desg FWD 0 128.14 P2p

9 Boson NetSim Lab Manual


5. When configuring EtherChannel using on mode, you should first shut down member interfaces until
both devices are configured. On CSW1, issue the following commands to stop all traffic across the
GigabitEthernet 0/1 and GigabitEthernet 0/2 interfaces, to complete the EtherChannel configuration,
and to re-enable the interfaces to bring the port channel up:

CSW1(config)#interface range gigabitethernet 0/1 - 2


CSW1(config-if-range)#shutdown
CSW1(config-if-range)#channel-group 2 mode on
CSW1(config-if-range)#no shutdown

6. On CSW1, issue the following command to verify that the GigabitEthernet 0/1 and GigabitEthernet
0/2 interfaces have been replaced with a Port-Channel 2 interface in the spanning tree on CSW1.
With only one interface in the forwarding state on each end of the link between DSW1 and CSW1,
you have verified that there should be no spanning tree loop. Sample output is shown below:

CSW1#show spanning-tree
VLAN0001
Spanning tree enabled protocol pvst
Root ID Priority 32768
Address 000C.1289.3959
This bridge is the root
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec

Bridge ID Priority 32768


Address 000C.1289.3959
Hello Time 2 sec Max Age 20 sec Forward Delay 15 sec
Aging Time 15

Interface Role Sts Cost Prio.Nbr Type


------------------- ---- --- --------- -------- -----------------------------
Po2 Desg FWD 0 128.16 P2p

10 Boson NetSim Lab Manual


Sample Configuration Scripts
ASW1 ASW1 (continued)
ASW1#show running-config interface FastEthernet0/6
Building configuration... switchport mode trunk
Current configuration : 1533 bytes channel-group 1 mode passive
! !
Version 15.b interface FastEthernet0/7
service timestamps debug uptime switchport mode trunk
service timestamps log uptime channel-group 1 mode passive
no service password-encryption !
! interface FastEthernet0/8
hostname ASW1 switchport mode trunk
! channel-group 1 mode passive
ip subnet-zero !
! interface FastEthernet0/9
ip cef switchport mode trunk
no ip domain-lookup channel-group 1 mode passive
lacp system-priority 100 !
spanning-tree mode pvst interface FastEthernet0/10
spanning-tree extend system-id switchport mode trunk
! channel-group 1 mode passive
interface Port-channel1 !
switchport mode trunk interface FastEthernet0/11
! switchport mode access
interface FastEthernet0/1 !
switchport mode trunk interface FastEthernet0/12
channel-group 1 mode passive !
shutdown interface Vlan 1
! no ip address
interface FastEthernet0/2 no ip route-cache
switchport mode trunk !
channel-group 1 mode passive ip classless
! no ip http server
interface FastEthernet0/3 !
switchport mode trunk line con 0
lacp port-priority 65535 line aux 0
channel-group 1 mode passive line vty 0 15
! login
interface FastEthernet0/4 !
switchport mode trunk no scheduler allocate
channel-group 1 mode passive end
!
interface FastEthernet0/5
switchport mode trunk
channel-group 1 mode passive
!

11 Boson NetSim Lab Manual


DSW1 DSW1 (continued)
DSW1#show running-config interface FastEthernet0/6
Building configuration... switchport trunk encapsulation dot1q
Current configuration : 2197 bytes switchport mode trunk
! channel-group 1 mode active
Version 15.b !
service timestamps debug uptime interface FastEthernet0/7
service timestamps log uptime switchport trunk encapsulation dot1q
no service password-encryption switchport mode trunk
! channel-group 1 mode active
hostname DSW1 !
! interface FastEthernet0/8
ip subnet-zero switchport trunk encapsulation dot1q
! switchport mode trunk
ip cef channel-group 1 mode active
no ip domain-lookup !
spanning-tree mode pvst interface FastEthernet0/9
spanning-tree extend system-id switchport trunk encapsulation dot1q
! switchport mode trunk
interface Port-channel1 channel-group 1 mode active
switchport trunk encapsulation dot1q !
switchport mode trunk interface FastEthernet0/10
! switchport trunk encapsulation dot1q
interface Port-channel2 switchport mode trunk
switchport trunk encapsulation dot1q channel-group 1 mode active
switchport mode trunk !
! interface FastEthernet0/11
interface FastEthernet0/1 !
switchport trunk encapsulation dot1q interface FastEthernet0/12
switchport mode trunk !
channel-group 1 mode active interface GigabitEthernet0/1
! switchport trunk encapsulation dot1q
interface FastEthernet0/2 switchport mode trunk
switchport trunk encapsulation dot1q channel-group 2 mode on
switchport mode trunk !
channel-group 1 mode active interface GigabitEthernet0/2
! switchport trunk encapsulation dot1q
interface FastEthernet0/3 switchport mode trunk
switchport trunk encapsulation dot1q channel-group 2 mode on
switchport mode trunk !
channel-group 1 mode active interface Vlan 1
! no ip address
interface FastEthernet0/4 no ip route-cache
switchport trunk encapsulation dot1q !
switchport mode trunk ip classless
channel-group 1 mode active no ip http server
! !
interface FastEthernet0/5 line con 0
switchport trunk encapsulation dot1q line aux 0
switchport mode trunk line vty 0 4
channel-group 1 mode active login
! !
no scheduler allocate
end

Copyright © 1996–2017 Boson Software, LLC. All rights reserved. NetSim software and documentation are protected by copyright law.

12 Boson NetSim Lab Manual

You might also like